Authentic Chained Data Containers TolP Technical Working Group Task Force Wiki: https:/jwiki.trustoverip.org/display/HOME/ACDC+%28Authentic+ Chained+Data+Container%29+Task+Force Slack: tswg-acdctf Github: _ https://github.com/trustoverip/TSS0033-technology-stack-acdc White Paper: https://github.com/SmithSamuelM/Papers/blob/master/whitepapers/ACDC.web.pdf Samuel M. Smith Ph.D. sam@samuelsmith.org. vios 20310719
Authentic Data Container = Attestation Testator ID: (Attestation Controller) (combined Testator/Attestator ID) (Rssume DID like namespace) (Argument to restrict attestation ID to always be in namespace of Testator 1D) (either implicitly or explicitly) Derived from Data Ttem Content (such as https://iscc.codes) (correlate attestations)
Attestation to Data Item (Datum) with source Datums S S ———— et Ve sion o el Attt o s Dot Datum ID = ID of Decentralized Attestation to Data , Decentralized Autonomic Data (DAD) : .
Example S —————— . ) prtsspirruig | )
Provenance Semantics: Chaining and Rules Provenance Chains (Credence or Authorization) { { {source: id, rules: { ..}, weight: value, .}, {source: id, rules: { ..}, weight: value, ..}, I destination: id, //issuer rules: { I weisnt: value, sink: id, //issuee ¥
Issues Linked Data
Provenance Semantics: Chaining and Rules ; - S o ) ,%*“ :@ - - L“E ‘:}: - - Eell =R P
Provenance Semantics: Chaining and Rules =l gg ==
sl sk 3
Its all about Automated Reasoning Automated Business Process Workflows as Automated Decision Processes Secure Attribution is essential to cross entity decision processes and cross entity data supporting those decision processes. Decentralized Automated Decision Making depends on securely attributable decision process data flows. Secure Attribution provided by a portable decentralized identity system security overlay for data in motion and at rest. Automated Reasoning with Authentic Data Decision Making: finding actions that best satisfy goals and constraints
Authentic = Provenanced = Securely Attributed Securely Attributed = Nonrepudiably Authenticated T - o Secure Attribution (Authentic Provenance): I a4 Chain, Tree, or Graph - *,/7;
Authenticity Verification Digital Signatures for Verifiable Authenticity Verifiable Authenticity = Authenticatible Securely Attributable via Verifiable Non-repudiable Digital Signatures Authenticity Verification Models (for VCs)
Terminology credential: evidence of authority, status, rights, entitlement to privileges, or the like. license: formal permission from a constituted authority to do something, as to carry on some business or profession. a certificate, tag, plate, etc., giving proof of such permission; official permit: adriver's license. authorization: permission or power granted by an authority; sanction. In decision making context, authentic credential = proof of satisfaction of authority constraint
Authenticity Verification (Attribution/Provenance) Model Properties Bipartite vs. Tripartite vs. Multipartite Open Loop vs. Closed Loop Chained vs. Unchained Aggregative vs. Unaggregative Weighted vs. Unweighted (Qualified vs Unqualified) Attenuable vs. Unattenuable Persistent vs. Ephemeral Implicit vs. Explicit Cooperative vs. Uncooperative (Unilateral vs. Bilateral vs. Multilateral) Entrained vs. Unentrained
Issuer-Holder-Verifier Model Issuance Presentation Issuer Holder Verifier
Issuer-Holder-Verifier Model with Verification at Verifiable Data Registry Issuance Presentation lssuer | Holder Verifier _ Registration Registration Verifiable Verification Data Registry
Issuer-Holder-Verifier Model with Verification at Issuer Issuance Presentation Issuer Holder Verifier Verification
Issuer-Holder Model with Verification at Issuer Issuance Issuer {Verifler ‘ % Holder ‘ l Presentation/Verification l
Joint Delegator-Service Model D;I:f;l:r Authorization Delegate Authorization Delegate Authorization Delegate Service Attenuated Attenuated Attenuated
St Delegator-Seice Model Dogaor| MBI | g | AN | poggy | Adhorusion | pgog | Presenision | Source Atenuated Atenuated, Atenuated
Closed Loop Joint Model " D;m:tear Authorization { Delegate Authorzaon | pece | Authorization ‘ Delogate peovied Attenuated Attenuated Attenuated f Verification and Presentation
Giosed Loop Spit Model ogatr | AR | gy | AN | | Atotzton | gy, | Preenain [ Source Attenuated Atienuated ”| Atenuated ; L J L J L L J Verficaton
Open Loop Spit Mogel Deegator | AN | gy | AMONN | pggy | AT | gy | Proserilen Sowce " |Atenvaled Atenualsd Atenuated Registation Registraton Regstation Verfable Verifcation Data < Regisry
References Buchner, D., Zundel, B. and Riedel, M., “Presentation Exchange,” Decentralized Identity Foundation (DIF), https:/jidentity.foundationipresentation-exchange/ Conway, 5., Hughes, A, Ma, M. et al., “A DID for Everything,” Rebooting the Web of Trust RWOT 7, 2018/09/26 https://github.com/SmithSamuelM/Papers/ blobjmasterfuhitepapers(A_DID_for_everything pd Ellison, C., Frantz, B., Lampson, B. et al, “RFC 2693 SPKI Certificate Theory,” IETF, 1999/00/o1 https:/jwww.rfc-editor.orglricirfc2693.txt Evernym, “Simple Grant Language (SGL),” httpsgithub.comievernymisgl Hardman, D., “Aries RFC 0103; Indirect Identity Control,” HyperLedger Aries, 2019-06-04 https:figithub.comjhyperledger/aries rfcsfblobjmastericoncepts/o1o3- IndirectidentitycontroREADME md Hardman, D. and Harchandani, L, “Aries RFC 0104: Chained Credentials,” 2019.11-04 https:jgithub.comfhyperledgerfaries.rfcsfblobfmaster/conceptsfotos- chained-redentils[README md Hartzog, W, “Chain Link Confidentiality,” Georgia Law Review, vol. 46 657, p- 48, 2012104124 https:papers.ssm.comisol3lpapers.cimeabstract_id2045818 “IDESG Consent o Create Binding,” IDESG IDENTIRAMA, https:ikidesg orghwikiindesx phpiConsent_to_Create_Binding 150 27560 Consent record Information structure (Draft) 0, httpsjww.s027001security.comiherf7560. bl Kathrein, A, Lizar, M. and Tumer, D, “Consent Recelpt Speclficaton ..0,” Kantara iiatve 2019/2130 hitpsi{kantaraiiiative.orgldovnload/7903/ “Object capbiity model,” Wikipedia, htpss/en vkipecia.orgiwkiObject capabilty_mocil Ruff, T., “Verifiable Credentials Aren't Credentials. They're Containers.,” Medium, 2020-0714 https:/jrufftimo.medium.com/verifiable-credentials-arent- redentils they e-containers fabsbaesco Ruf, T, “Like Shipping Containers,Verifable Credentals Wil Economically Transform the World,” Mediu, 20206714 htps:ufftimo medium.comfike- shipping:<ontainers-veriable.credentias-vil-economically-transform-theworldfecezbodaida Ruff, T, “How Verfable redentils Bridge Trust Domains,” Medium, 2020-07-1 httpsruftimo,mediumcomjhowverifable-credentials bridge trust domains spissdoficiy Smith, S. M., “Universal Identifier Theory,” 20201023 https{github.com/SmithSamuelM/Papers{blobjmasterfwhitepapers/identifierTheory_web.pdf Smith, S. M., “Decentralized Autonomic Data (DAD) and the three R's of Key Management,” Rebooting the Web of Trust RWOT 6, Spring 2018 htps:f/ github comjSmithsamuelfPapersiblobjmasterfhitepapers(DecentralizedAutonomicData pdf “wscccg Taceabllty Vocabulary Specii
cation, w3c-ccg, htpsigthub.comw3cccgfraceabilty-vocab Webber, C. ., Sporny, M. and Milr, M. ., “Authorlzation Capabiltes for Linked Data v0.3 (ZCAP-LD):An abject capabilty framework for linked data systems,” W3C, 2020/Octoberf22 https:ffw3c-ccg.github.iofzcap-ldf
Object Capabilities vs VC Authorizations ObjCap: Most useful for computer OS security, does not translate easily to many real world use cases Not VC Native explicit, ephemeral, attenuable, chained, unaggregative, unweighted, uncooperative, closed-loop VG No standard model for authorization, chaining, delegation etc. Implicit, persistant or not, unattenuable, unchained, unaggregative, unweighted, uncooperative, open-loop
Verifiable Chains Verifiable Credential Native: Chaining Semantics: Provenance Credence (Trust) Confidence Data Custody Authorization Consent Custodian Governance TADA’!
Samuel M. Smith Ph.D. sam@samuelsmith.org